Wednesday 12th June 2019

Agreements Network Systemic Bug Identified

We have identified a major bug in the suite of smart contracts underlying the Agreements Network testnets. We are working on a fix. At this time we do not expect that there will be any loss of data or functionality when we have patched the bug.

Update: we've identified the root cause of the problem and will be testing a fix shortly.

Update (2136 BST) the fix has been deployed and appears holding, we are turning on traffic for some users.

Update (2150 BST) the fix appears to be holding for all objects in the merkle tree, we are turning on traffic for all users. Please do report any failures or challenges as usual.